Go to www.hooktheory.com

"Dict Opt" under chord names in TheoryTab

Hiya! Ran into a strange bug when updating this Theorytab. I’m not entirely sure what I did, but I was typing the description of my edit when suddenly the chords in the last measure turned into “Dict Opt” instead of the chord names (G and E). It still says that now, even though it’s published.

image

Changing them to different chords without otherwise modifying them didn’t fix it (they still said “Dict Opt”), but I resolved the issue by deleting and re-adding the chords.

1 Like

This is happening to me on over and over on one piece I keep trying to add lyrics to.

I suspect Dict Opt is Dict Options - is a Python language term. Be very afraid, this bug can obliterate your saved composition by automatically writing a junk file over your work. If you need to keep working while this issue is being fixed, save your files twice with different file names.

I sent him a detailed example.
I have noticed it on the file save and also the section naming.

Work around until they get it fixed:

If it does that, IMMEDIATELY go to the menu under file and grab an earlier version from the autobackup.

It doesn’t fix anything but it does keep you from losing your work.

I just keep using the default text to avoid getting bitten by it. I believe it is something in the text entry for the dialogs. I am exporting it to a midi file anyway so I just save it as untitled and don’t change names of stuff until I have it in Cakewalk.

I’m having a similar problem, although when I tried to change a lyric, it not only changed the chords to Dict Opt, but also completely changed my composition. I closed and reopened the file and found most of it intact. I have since saved a few copies and tried to change the lyric but get the dame disruptive result.

I’m afraid to open other compositions in case the same thing happens.

Just tried a new file. Put in a few chords and a melody. Clicked save, and when I typed in the name of the file it changed my chords and melody. I hit save and reopened. My melody was gone and the new melody bits were there along with an Adele song? Wacky!

Seems like it’s unusable until a fix is found.

I’m using Windows 11, Edge browser. Maybe I’ll try another browser and see what happens…

Same thing happening in Chrome.

Just lost about 2 hours work with Dict Opt error >>>not happy :frowning:

1 Like

Hi all,

Sorry about this, this should now be fixed in 2.25.1, live now. If you’ve saved a project where some chords were munged you might be able to use the “Recover from auto-backup” from the file menu to recover the last working version.