Go to www.hooktheory.com

Zero cursor latency

I don’t know if there are latency issues in all online DAWs, so I’m asking if they are on the way to fix it or if it is fixed by buying an external audio interface card or if there is no solution.
On the other hand, I don’t know if it’s possible to play melodies with a midi controller at the same time as the accompanying chords, it would be great if it could.
In the import of midi melodies it also seems that there are problems.

Please excuse the translation if it creates any confusion.

Hi there, not sure which latency you’re referring to here, but if you’d like better placement accuracy for notes inputted from your midi controller in record mode, you can use the input latency slider in preferences:

That latency I mean exactly.
Even if you slide the cursor to zero, it is impossible to play a reasonable melody with the Midi keyboard. That’s why I ask if it’s a general problem to solve or I should buy an external audio interface, make more adjustments in Windows or something like that.
I don’t have any problems with a DAW, and if there are any, they are solved with Asio4all.

It dawns on me now that our description of what this is doing is pretty unclear. The point of this slider is to compensate for input latency that your controller has with the browser (rather than controlling the latency itself). So if your notes are entering in late, you need to use a larger value to compensate.

Unlike a DAW, we can’t have a direct connection to the midi controller, and instead rely on the browser to communicate midi messages.

In our experience though, adjusting this slider is usually enough to get workable midi input timings even on laggy browsers.

To break down the problem a bit more, I think there are two latencies here.
The first one is how much time your audio driver needs to produce the sound you hear after you press a key on your midi controller. There we have no influence in Hookpad itself. This might depend on your audio driver’s buffer setting. If you can try setting the buffer of your audio driver as small as possible. In your DAW a standard buffer setting is 128 samples. This is in most cases slow enough to give the computer enough time to perform all audio calculations but at the same time it’s fast enough to be able to play a midi controller in real time.

The second latency is where a midi note is written into Hookpad when recording notes with your midi controller. This is what the slider is referring to. (After you have fixed the first latency problem) I recommend recording a bunch of eighth notes to a drum beat and adjust the slider until Hookpad writes the eighth notes exactly where you wanted to record them. For me a latency of 70ms works best but that depends on you buffer size and how early you play your notes to adjust to the buffer you hear etc. so it might be something completely different for you.

OK thank you.
I will see if I have the option to configure the buffer of my audio driver.
I’ll do some tests and let you know.

OK thank you.
I’ll run some tests and tell you how she’s done.

After messing around everywhere and testing the latency with the speed test that gives me 16 milliseconds and several other things like this support.native-instruments.com/hc/es/art…o-en-Windows

I have found an equalizer program that I have installed and that I did not remember Boom3D - Best Volume Booster & Equalizer for Mac and Windows and that sounds very good but just by deactivating it the latency drops to much more reasonable levels.

Although I will continue investigating and I am calmer and more comfortable when recording.

Thank you.

Oh, wow. I’m glad you found something!
As much as a tool like “Boom” might enhance your media experience when consuming media I would always turn it off when creating media. After all you want your sound as clear and clean as possible to be able to make musical and sound decisions. But I guess your DAW skips the “Boom” tool anyway as DAWS are usually connected directly to an output of an interface.

That’s right, with neither of my two offline DAWs had I had any problems.
Fortunately I noticed the installation of Boom 3D, and for now it’s fixed.
Thank you very much.