What gives with external MIDI control and Hookpad+

Continuing the discussion from Midi Input will not work:

August 18, 2 weeks to go on my annual hookpad+ subscription and external keyboard through latest Chrome with Jazz-MIDI installed simply does not work.
Wasted hours trying.
Not in the mood to resubscribe.
MIDI help on the official help section of Hooktheory support is virtually absent.
This forum seems not have any stickies that fast track users to MIDI fixes.

Hi all,

We’ve diagnosed that there seems to be an issue with Chrome’s implementation of the Web MIDI API whereby midi messages are occasionally reported on incorrect ports, meaning that if you have more than one midi devices attached, sometimes incoming midi messages are labeled with the port numbers of the wrong device. We’re looking into a workaround, but for now, if you have more than one midi device attached, try turning them all to “input”, as there’s a chance that the device you are trying to use is being mislabeled.

OK, so the issue is with Chriome.
Unexpected, you have my apologies.
I tried to reduce the number of MIDI sources to just a handful and switched them all on. This worked to a point.
Yes the MIDI now flows from external keybaord to Hookpad+ (I also witnessed the Chrome port confusion earlier before I simplified.
However the current situation is Hookpad+ is receiving the same note, no matter what key is pressed on the external keyboard.

I tested this by using the computer keyboard, fine, the notes change with the numbers pressed. But the external keyboard, same note all the time.
So there is more than 1 issue here.


Very sorry about this, while debugging this we accidentally reverted to some code that is messing up chord input (all I chords as you’ve pointed out), and the octaves of note entry are also incorrect for keys other than C major. We’ll have this all sorted out shortly, but just want to make sure that this latest build is stable before releasing. We appreciate your patience on this and apologize for these issues

Hi, waiting for the new build to arrive. Have jury rigged a different PC with just one midi source to drive hookpad+ with the Google API bug. Now all I need is more than chord 1.

Are you making progress on the build?

My annual subscription is due about now, dilemma renew whilst not knowing if the new build is going to work. Or lapse membership and not know as cannot use + to find out!

Sorry for the delay, it will go up either tonight or tomorrow. This ended up being bundled into a pretty major update to Hookpad so it has taken us a little longer to make sure that everything is working properly.

Hi, so now there NO MIDI DEVICES appearing in Hookpad+, on both my Macs.
Have you done an update to switch this function off?

I can now also confirm the same thing is happening on my Windows 7 laptop.
MIDI is arriving into Chrome but Hookpad+ says NO MIDI devices avalable.
It was working a few days ago! What changed?
(He says after the automatic annual renewal went through on my Hooktheory subscription, that I was seriously considering not renewing)
So thats a Mac, a Macbook and a Laptop PC that says no MIDI in Hookpad, when MIDI IS available to the computer and Chrome.

@PadburyMusicIan Thanks and apologies. We think we have identified what is causing your issue and should have a fix pushed shortly!


Hi. The current build of Hookpad+ continues not to accept MIDI from external keyboard.

Is it working for you in your test lab? What hardware are you testing it with?
Maybe you should change it out and try something different.
Try a Macbook Air with an Arturia keyboard. I’ll lend you mine.

For the record:
I see that the Hookpad MIDI menu has gone from blank, back to the detected MIDI inputs menu and I can select all inputs on that menu.
I have the latest chrome,
JazzMIDI enabled,
The Hookpad/test-MIDI web page shows MIDI arriving into that web page as notes are played on the external keyboard,
2 separate keyboards were tried, both showed MIDI arriving on the test-MIDI page.
I am selecting MIDI in on all rows of the Hookpad+ MIDI menu (there are 3)
I have a single MIDI keyboard and no other MIDI devices connected to the Macbook Air directly by USB cable.
In the same session I can switch web pages and use the Skoove online instrument, inputting MIDI to play the Skoove onscreen piano, there is no problem with MIDI arriving into the Skoove web app.

I got your “Hookpad 2 has been released” email today, which is ironic.

I also note that the release notes for the last few builds do not mention MIDI at all.

Thanks for the detailed report. We are working through some known issues and will provide updates tomorrow.


Glad that your controller is now properly showing up in the MIDI menu. You mention that you only have the one midi controller (Arturia) plugged in, but you have 3 devices showing up in the menu? We are working through an issue where sometimes the port numbers for multiple midi devices are not being mapped properly through the Chrome Web MIDI API. I apologize for the lack of progress here, this issue does not happen on any of our midi controllers so it’s been difficult to isolate the problem.

I know this is super frustrating, and we are planning to address this by temporarily reorganizing the gateway so that Hookpad accepts all incoming MIDI messages, until we can reliably figure this out (this is the way it was in the previous version of Hookpad).

I think that I’m having the same problem. I have “enabled” MIDI input in Hoodpad and the MIDI test seems to work. But the keyboard is not talking to Hookpad. All the MIDI seem it be set for input. I want to roll this out to the student lab computers, soon. Are there any updates or suggestions.

Hey @akravitz, is this for Hookpad v2 or for v1?

Just some clarification, the new version of Hookpad has a global enable/disable, so you shouldn’t need to set each midi device to input.

t’s version 2.1.6 and I checked the “enable” button.
Screen Shot 2018-09-12 at 8.52.14 AM.png

We’re planning on posting We’ve posted a MIDI console to Hookpad which will log midi messages coming in. Hopefully this will help us determine if Hookpad is able to see these messages.

Once the console is enabled you should see all messages detected by Hookpad displayed. For all those experiencing issues with this, please let us know if your controllers are outputting anything to the MIDI console.

I used the new system, connected a MIDI keyboard, the console said I see your keyboard and recorded my keystrokes, but no notes were added to Hookpad in chord or melody sections.

I used the computer keyboard to add notes as normal, so it’s still the MIDI input only that is not working.

Thanks for the report. It does appear that Hookpad is at least communicating with your controller, which is good news. We’re going to put some more detailed logging in place to zero in on what the issue is.

Hi all, we’ve put some additional logging in place in the midi console. If any of you are still having issues with Hookpad not recognizing your controller could you please post a screenshot?

Not working for me. Works on test site though.