Go to www.hooktheory.com

Other sounds than piano don't seem to work

Hi,

I was wondering why I couldn’t hear anything but drums in a song that I had written. Then I changed the band to have all lead voices as piano an it started working. I created a simple test file to duplicate the problem. Happened on Mac in Chrome.

Here’s the JSON test file:
{“version”:1,“chords”:[{“root”:2,“beat”:1,“duration”:4,“type”:5,“inversion”:0,“applied”:0,“adds”:[],“omits”:[],“alterations”:[],“suspensions”:[],“pedal”:null,“alternate”:"",“borrowed”:"",“isRest”:false},{“root”:1,“beat”:5,“duration”:4,“type”:5,“inversion”:0,“applied”:0,“adds”:[],“omits”:[],“alterations”:[],“suspensions”:[],“pedal”:null,“alternate”:"",“borrowed”:"",“isRest”:false}],“notes”:[{“sd”:“4”,“octave”:0,“beat”:1,“duration”:4,“isRest”:false},{“sd”:“3”,“octave”:0,“beat”:5,“duration”:4,“isRest”:false}],“keys”:[{“beat”:1,“scale”:“major”,“tonic”:“C”}],“tempos”:[{“beat”:1,“bpm”:120,“swingFactor”:0,“swingBeat”:0.5}],“meters”:[{“beat”:1,“numBeats”:4,“beatUnit”:1}],“breaks”:[],“bands”:[{“beat”:1,“lead1”:[{“mute”:false,“octaveOffset”:0,“velocity”:0.7,“specification”:“Clean Electric Lead Sustain”,“midiChannel”:1,“useHookpadOutput”:true,“useMIDIOutput”:true}],“lead2”:[{“mute”:false,“octaveOffset”:0,“velocity”:0.7,“specification”:“Piano Lead”,“midiChannel”:2,“useHookpadOutput”:true,“useMIDIOutput”:true}],“lead3”:[{“mute”:false,“octaveOffset”:0,“velocity”:0.7,“specification”:“Piano Lead”,“midiChannel”:3,“useHookpadOutput”:true,“useMIDIOutput”:true}],“lead4”:[{“mute”:false,“octaveOffset”:0,“velocity”:0.7,“specification”:“Piano Lead”,“midiChannel”:4,“useHookpadOutput”:true,“useMIDIOutput”:true}],“harmony”:[{“octaveOffset”:0,“velocity”:0.7,“specification”:“Piano 1/4s”,“midiChannel”:5,“useHookpadOutput”:true,“useMIDIOutput”:true}],“bass”:[{“octaveOffset”:0,“velocity”:0.7,“specification”:“Piano Bass Dotted”,“midiChannel”:9,“useHookpadOutput”:true,“useMIDIOutput”:false}],“drums”:[{“octaveOffset”:0,“velocity”:0.7,“specification”:“Basic Pop”,“midiChannel”:10,“useHookpadOutput”:false,“useMIDIOutput”:false}]}],“lyrics”:{“isOpen”:false,“isFocused”:false,“values”:["","","",""]},“cursor”:{“beat”:9,“location”:“cursor-note-staff”},“settings”:{“widthBeat”:36,“metronome”:false,“keyDiffMode”:“key-diff-ryan”,“showOnlyStableInStaff”:false,“relativeNotation”:true,“entryMode”:“entry-mode-table”,“staffMode”:“collapsed”,“wrapMode”:“wrap-mode-fixed-mreasures-per-line”,“wrapModeMeasuresPerLine”:8,“colorMode”:“diatonic-centric”,“colorTheme”:“color-theme-light”,“smartOctave”:true,“zoom”:1,“midiOutputLatency”:0,“magicAuditionType”:“magic-audition-full”,“inactiveMelodyDisplay”:“inactive-melody-colored-by-index”},“loopGui”:{“looping”:true,“beat”:1,“duration”:8},“youtube”:{“syncEnd”:0.15,“enableYouTube”:true,“mouseDownSyncStart”:0,“youtubeSyncMode”:“sync-linked-to-youtube”,“syncStart”:0.05,“mouseDown”:false,“playerError”:null,“videoInitializing”:false,“playing”:false,“videoDuration”:null,“playerState”:null,“mouseDownSyncIndex”:null,“mouseDownX”:0,“isPlayerOnParent”:false,“isOpen”:true,“idDiv”:“hookpad-youtube-player”,“syncEndAbsoluteHookpad1”:null,“isCueing”:false,“isLoadOpen”:false,“mouseDownOver”:"",“id”:"",“playAfterDurationIsSet”:false,“mosueDownSyncEnd”:0,“syncCurrent”:0,“playbackMode”:“instrument-playback”,“syncMode”:“youtube-sync-mode-set-start-and-end”,“requestPlayAfterNextStateChangeToPaused”:false,“loadingApi”:false,“syncStartAbsoluteHookpad1”:null,“cueVideoOnGetSongSuccess”:true,“keyFramesForSync”:[]},“keyFrames”:[{“beat”:1},{“beat”:33}],“activeMelodyIndex”:0,“endBeat”:65,“inactiveNotes”:[[],[],[],[]],“visibleMelodies”:[0,1,2,3],“soloAndMutedMelodies”:{“mutedMelodies”:[false,false,false,false],“soloMelodies”:[true,true,true,true],“soloHarmony”:true,“soloBass”:true,“soloDrums”:true,“volume”:1,“metronomeVolume”:0.3},“pickup”:false,“fp”:“9ee656f29c7ff0adf48e1181a0c1b9080837442e”}

Pasi

The sounds are working now. Don’t know if they started working after I rebooted my computer or if something on the server side changed.