Octave slider in the Instrument Mixer has unreachable settings

The octave slider in the new Instrument Mixer doesn’t always allow all twelve semitones.

Steps to reproduce:

  1. New project
  2. Insert an I chord (C)
  3. Insert a ♭II chord, either from phrygian or as a tritone sub of V/I (D♭)
  4. Choose Synth Bass > Acid Pluck
  5. Open the Instsrument Mixer
  6. In the Instrument Mixer sidebar, compare the two bass notes when octave is set to -1 vs -2.

The two base notes, while a semitone apart, jump together. When the old octave slider is set to -1, the bass notes are split an octave apart as they should be. On the default piano bass, -4 on either slider splits these same semitones.

believe the “octave” slider is only showing semi-times per # - so 12 or -12 = octave.

Yes, you’re right. When I’m using your setting and trying to play the notes C - Db - D the following should happen:

  • OCS 0: All three notes have the same octave
  • OSC -1: D gets transposed down
  • OSC -2: Db gets also transposed down
  • OSC -3: C gets also transposed

But currently at -2 the C gets also transposed down. I have to investigate this. There are multiple conversions involved. Perhaps this is just a rounding error.

Thanks for pointing this out!
Dennis