New version unusable

Hi there, I’ve just logged into Hookpad and find the product completely unusable. The software is constantly adding new rows to my composition, placing the cursor on the first measure and clicking play doesn’t work and the entire process of adding or removing chords is impossibly difficult.

Is this still in beta? Sorry, but I’m incredibly frustrated after loving the previous version. Also, when I tried the support link from within Hookpad, I get refused to connect.

1 Like

@smithenstein thanks for the feedback. At least some of this behavior seems by design.

In general, Hookpad will automatically add new empty measures ( a line worth) to your song if you try to add notes beyond the last measure. Is it doing this is some other circumstance?

Regarding note/chord entry being more complicated, the new version defaults to a new input scheme more in line with how DAWs like Garageband work. If you like the old one better you can go to the upper right and click “TXT entry” mode. This will put the entry mode to how it worked before which can be more intuitive ( more like a text editor). The new mode is nice because your music doesn’t shift when you add notes in the middle of a line, but it does allow you to overwrite notes so it’s not as simple, perhaps.

We’ll check the link to the forum.

You can also continue to use the previous version for the foreseeable future by clicking the Hooktheory menu in the upper right and choosing v 1.8.x.

Definitely interested to hear your comments on the new version thoguh as it is the future, and we want to make sure it is not confusing or hard to use.


I gave the new version another try today, and it’s very unusable for me.

  • I cannot copy-paste anything
  • I cannot undo anything with Ctrl-Z
  • I cannot select all with Ctrl-A
  • I cannot delete notes with Delete
  • Moving notes/chords should display an appropriate cursor, otherwise the behavior is confusing
  • The loop region thing is visually unintuitive (and how do I remove it after adding it?)
  • The tempo slider is too small to select some BPMs
  • The tempo slider sometimes doesn’t work, as moving it will instead try to drag-and-drop the entire interface
  • Hovering the account link while having another popup open will instantly open the account popup instead
  • Selections should update even if the cursor is outside of the tab area (add the mousemove/mouseup event listeners to window)
  • “On Insert” mode should reasonably be remembered the next time you open Hookpad
  • I still very much want a normal click-to-add-note functionality, especially as note overwriting exists now anyway
  • The console is full of errors, mostly “/hookpad-app/2.1.3/static/js/main.7ac9606d-public.js:1 Uncaught TypeError: Cannot read property ‘get’ of undefined” spam
  • If I resize the window, the entire page goddamn disappears permanently. The error is “main.7ac9606d-public.js:1 Uncaught TypeError: Cannot read property ‘getBoundingClientRect’ of null”

I see many promising things in the interface, but I unfortunately cannot use this service as it stands (after 4½ years of use). I hope most of these problems will be resolved soon, and I’ll be back.

@Quaeria Thanks for all the good feedback. I’m have some suggestions that should help with a lot of these concerns, and we’ll work on the others.

Copy paste undo select all shortcuts don’t use ctrl. Just hit c/v/x/z/a etc. and it should work (let me know if it doesn’t). We will look into making it work with control. The old version of Hookpad also just used c/v/x/z/a but for some reason on a lot of browsers it would still work with ctrl held down. This doesn’t seem to be the case with HP2. Since the the copying etc. is not using the browser native functions we wanted to differentiate it by not using ctrl, but will revisit this.

What browser OS are you using that delete (backspace) doesn’t work? We haven’t had any one else complain about that one.

We can make the tempo slider have 1 bpm draggable granularity by making it bigger. You can use the +/- buttons to the left/right of the slider for this now though to get the exact tempo you want. It’s an extra click or two. In order to make the slider have single bpm granularity it has to be pretty big since one pixel = 1 bpm and we wanted to support a large range.

The Loop bar can be deactivated by clicking on it (it will turn gray). In general, we tried to make it work exactly like other DAWs behave (like Garageband/logic for exampel). I agree it could be more intuitive but in the end we thought consistency with other programs was important.

Agree about remembering your choice for insert mode default. We can make that a setting. The keyboard shortcut for this is ‘m’ (for ‘mode’) so it’s pretty easy to switch back and forth. We actually designed the mode to be switched back and forth depending on how you are editing and didn’t think of it as a permanent setting.

Not sure where those ‘get’ errors are coming from. Are they affecting functionality? If you know a super simple way to reproduce consistently from a blank song we can probably fix. In our development environment errors like that halt the program entirely even if they aren’t hurting anything so there shouldn’t be too many of them. We will look into the resize window issue. It doesn’t happen to me at the moment but perhaps it’s browser specific.

Thanks for all the feedback. We’ll continue to improve. Hopefully some of those suggestions make it more usable. I can imagine not having copy/paste/undo or delete would be pretty frustrating!