New version 2.19.12 do not allow copy

It seems the new version has a bug that does not allow copying and pasting. It used to work all right, but, for some reason, now it does not work well. Sometimes, when is just a measure or two, it copies, but if it larger it does not work.

I am using chrome (latest) over W7

Note: I wonder if someone else has noticed it, because it does not always happen

1 Like

I noticed this today. I attempted to copy four measures in a melody section (using paste from clipboard), but strangely only two came across. I tried more than once. I just ended up pasting them separately.
I am using PWA/Edge on W10.

Sorry for the late response, we’re not seeing this bug, are you able to reproduce it consistently? Are you selecting using the measure region, or just notes/chords in the staff? Does it happen on all songs or just sometimes? Thanks!

It is still present, but it is not bothering me any more

After some experimentation, I presume it is related to the entry mode (app settings)

If I start a new composition, and use “table”, everything goes fine. I can copy and paste.
If then I change settings to “text” it does not work any more. I can copy, but cannot paste except at the end of the piece, and only if there are enough free measures. (sometimes also works when I create enough empty measures at the end)
I have “auto add measures” always enabled

When I go back to “table” it works all right

What I have done is just ignore “text” mode

Thank you for your interest

I think I understand what is happening and this may not be a bug, just confusing behavior. In text mode, music shifts to the right when you paste (in line with the text editor metaphor where words shift on paste). If a line is completely full of music (I,e notes go to the end of a line) then there is no space for the music to shift to and the system will detect this and disallow the paste. You need to delete what is there first (or select it so it deletes the selection when you paste). We will consider adding a message stating why paste was not allowed to make this more obvious. Most of our users use the default table mode which pastes destructively over existing music and don’t see this.


1 Like