Midi keyboard won't play single notes

I’m very new to writing music, and I have a cheap and cheerful Keystation Mini32 Mk3, which I’m still getting to grips with. When I use it with the DAW it comes with, I can assign a sound to it and hear single notes or multi-finger chords fine. However, in Hookpad, I can’t - I can change the instrument, but there are piano chords that also playback under every note that I can’t get rid of, that bear no relation to any chords that I might have chosen to enter under the staff. The result is a frustrating clash that that makes it impossible to properly experiment or improvise. E.g. - I think pressing C on it’s own plays a C major piano chord with a C in whatever instrument I’ve manually selected on top, which sucks if I’m trying to see how it sounds over a different chord.

Some observations:

  • Adjusting the mixer doesn’t fix this, and nor does deleting voices from the band.

  • The issue is also present if I try to play scales using my keyboard in the Hooktheory free preview.

  • Sometimes if I haven’t played anything for a few minutes, there will be a short latency (5-10 seconds or so) where I get a few notes by themselves, but the unwanted chords always kick back in and then won’t go away at all until the next “break” from playing. .

  • While the “chord” sound is playing back and confusing things, Hookpad is correctly recording/entering either single-note melody OR single-note-press chords depending on where the cursor is (Though when I’m using it to enter chords, it seems to seems to randomly give me complex voicings or chords borrowed from other modes that I’ve not chosen, and I can’t figure out why).If the cursor is on the chord line, I only hear the chord as expected, and playback by clicking the play button is also fine with no unexpected piano chords, so the big problem seems to be with playing melody with the keyboard only.

Any help here? Suspect it’s got something to do with the default midi sound in Chrome, but how do I edit these if that’s the case?

With full acknowledgement that I’m a beginner and maybe expecting things to be more intuitive than they ever are in practice, I was really hoping that having the midi keyboard would make Hookpad more of a playground than it was when I was doing everything by point-and-click. However, it’s not been a great experience so far and I’ve not found anyone else who seems to have this issue.

Thanks for any pointers!

What gets play depends on what is selected.

If you are in the chords bar, it will make guesses about what chord you are playing.

If you are in the melody section, it will play individual notes.

Hi and sorry for your troubles!

So when all goes right, if your cursor is in the melody region, you should hear the melody instrument, and if it’s in the chord region, you should hear your band instruments playing chords in the key of your opened project.
One possible reason for hearing more than that would be a second app running in the background which also takes midi commands. For example if a second instance of Hookpad with a selected chord region is running on an inactive tab of your browser, this instance would also receive all your Midi notes and play sounds for them. The same would happen, if a DAW with an active Midi instrument was opened in the background.

I know that this is a pretty obvious thing, but it happens all the time for me, too. I’m often working in a DAW wandering where this rogue piano sound comes from until I detect an open instance of Hookpad on a browser I have totally forgotten that it is still open in the first place. One thing you can do if you don’t want to close that instance is to disable its MIDI input in the MIDI preferences.

Please let me know if this helped.