Go to www.hooktheory.com

Midi Input will not work

My midi support will not work whatsoever, I have tried using google chrome and also firefox, I’ve tried on multiple PCs, I can’t get it to work. I was going to upgrade to use hookpad+ for the midi exporting but I’m not going to if I can’t get the midi support to work… I know my controller is working because I have went through the trouble shooting on Jazz’ website and it recognizes my controller and my key presses. Please help.

I’m very sorry for the trouble and am sorry for all the time you’ve spent trying to get it working! We’ve had a few reports from others having difficulty yesterday (though it works for others) so there may be a problem on our end. We’re looking into it and will get back to you shortly. Thanks for reporting the issue here.

Dave

I had similar issues… Download chrome and Jazz-MIDI extension

My midi input does not work, but I have only been member of site for a month, so not completely sure how it is supposed to work. But I am using chrome on windows, and do see midi input on site https://airtightinteractive.com/demos/webmiditest/ But keyboard doesn’t do anything on hookpad+

I have the same problem :frowning: Tried it with Firefox and Chrome too. https://airtightinteractive.com/demos/webmiditest/ shows the correct midi inputs … is there a solution yet?

Hi @Zypresse,

Sorry for the trouble. When you load Hookpad in Firefox, does it show a banner that indicates that Hookpad is listening for MIDI input?

Also can you verify in settings that “Mute MIDI Input” is not checked?

Same here no MIDI input. Jazz installed and Settings/Disable Hookpad from responding to MIDI input by default is un-ticked and Mute MIDI Input is un-ticked. Keyboard definitely working.

Hi all,

Sorry for the trouble with this issue, it’s been extremely difficult for us to lock down why this is happening to some of you. We’re going to shortly push a MIDI debug page to give us some more information about what part of the MIDI input chain is failing. Since some users have reported having problems with Chrome (which uses Web MIDI API instead of the Jazz plugin) it may have something to do with messages being lost on their way to Hookpad. We’ll report back shortly.

@benson, We’ve created a MIDI test page to help debug the problem (it will ask you to login if you are not signed in when you visit the page). Can you try it and post what the page outputs?

Hi Ryan, I’m getting a 403/404 Error on that page. And something about Rick Ghastly :grinning:

That’s strange, are you clicking on the link or typing it in? As far as we can tell the page is working properly on our end

Clicking the link, but copied it just now and it’s still the same - Firefox and Chrome.

Hey @benson,

Are you still having trouble with this page? We can’t figure out why you wouldn’t be able to navigate there. Are any other users not able to access this page?

I’m having the exact same issue on my Mac and a 403 message came up in the midi test. I have paid for hookpad+ to have this feature available as well as export. I can see my file which is a midi file I made using score cloud and is on my desktop. When I try to import it using ‘open’ then clicking on ‘disk open’ and selecting my midi file, it tells me to ‘please choose a “hkt.” file’. It is not greyed out and I can select it, its just not recognising it as a file I am allowed to open. I have tried chrome and Safari and have downloaded the Jazz plugin. I have also installed flash as was out of date. Im sure you will work it out but in the mean time is incredibly frustrating.

Hi @tunesmith70,

Currently Hookpad does not support importing midi files directly into your Hookpad project (although this is something that we will support in the next version of Hookpad). Sorry for the confusion, and we would be happy to issue you a refund if you email support@hooktheory.com.

Thank you for your reply Ryan, do you have an estimated time when you expect the next version to be out?

When will there be an update? The midi export never worked.

@tunesmith70,

At this time we don’t have a release date set for the next version of Hookpad. We have big plans for this next major update that will incorporate a lot of the feedback and ideas that you all have provided us. We’ll definitely keep you posted on our progress.

@ericrolerkite, are you continuing to have problems with exporting MIDI files from Hookpad? If you are on Safari, have you tried the workaround for the Adobe bug detailed in here?

I’m also having trouble with running my keyboards through hookpad. I’ve troubleshooted it and found that my browser is recognizing midi just fine through this site (https://webaudiodemos.appspot.com/midi-synth/index.html) however Hookpad does not recognize the midi. So it has to be something with HookPad.

I would be a subscriber if this were working as it is a critical feature. Please fix!