Go to www.hooktheory.com

Lead Sheet exporting not working

When I export to “Lead Sheet” I get what you see in the screenshot. It used to work fine until about two months ago. Do you have a fix for it? I posted in another thread that I an unable to upgrade to version 2.8, and I’m still on V. 2.18.

Hi @Reidmoto,

You will need to update your Hookpad version in order to receive any fixes that we make. In most browsers, you can hold Shift and press the refresh button to update Hookpad.

Hi Ryan,

I posted another question about being unable to get the refresh to upgrade no matter what I’ve tried to do. I’m still on version 2.18.4. Is there any other way to get the current version besides Shift + Refresh buttons?

A question on “refresh” button, and I’ve tried both. Which refresh button are you referring to? The 3/4 circular arrow in Chrome? Command + R on the Mac keyboard, thus making it Shift + Command + R.
The F5 button? Or other?

BTW, I really enjoyed and learned a lot from the tutorial series you did on producing for film/movies. You did a great job of walking us through your thought processes about the choices you make, and it was very helpful and enlightening. Thank you.

I’m glad you liked that series! Feels a bit dated compared to some of the new YT videos these days, but I’m glad it was valuable to you.

So in Chrome, if you hold SHIFT and you physically click the 3/4 arrow refresh button, it should grab the latest version of the PWA. If this doesn’t work, there is a way to force this to happen:

In View -> Developer -> Developer Tools, you can click on Application tab. On the left side there’s something called “Clear storage”. Clearing this will delete the Hookpad app saved in your browser and then it will grab a new one once the page is reloaded.

1 Like

Hi Ryan,

Thank you for your answer. I tried to do what you said and I’m still at version
2.18. Here’s a short two-minute screencast https://www.screencast.com/t/7J2ZmHqH

What you saw on the screencast is my second try. The first time the Application tab
looked different and I clicked the button that said "Clear _____’ on the right pane.

I was holding down shift when I hit the refresh button.

I couldn’t record audio because everyone is asleep.

Best

Reid

Hi @Reidmoto, it’s important that when you do the refresh, you’re actually on the Hookpad screen hookpad.hooktheory.com (not the hookpad information page).

But looking at your video, it does appear you’re on a relatively recent version of Hookpad, 2.18 is more recent than 2.8, so I’m starting to think that the lead sheet problem is a different bug. Would you mind going to File → Save To Disk and sending the .json file for your song to me at ryan (at) hooktheory.com and I’ll try and see what’s going on? Thanks!

Hi @Ryan, I just emailed you the json file. Best, Reid

hi @Reidmoto, thanks for the email. The issue with the export is that your lead 1 track is muted in the band gui. Sheet music export ignores all muted tracks, so this is why the lead sheets are coming up with just the chords and no melody. If you’d like to mute playback but preserve exports of the melody, I would recommend using the mixer (shortcut u).

1 Like

HI @Ryan,

BOOM! that did the trick. Thank you so much for going out of your way to help me with this as it was really bothering me and hindering my recording process! Thank you for your email and your kind words too, I just sent you a reply.

You guys are the best!

Grateful,

Reid