Keyboard Shortcuts for creating 7ths, Inversions, and Secondary Chords broke immedietely after purchasing

Hi - using a Macbook Pro 2019 13 inch, MacOs Monterey 12.4, working perfectly untill I purchased but the shortcuts immeditetely broke after purchasing 1 month.

  • Caps lock is off
  • All other shortcuts ARE working

Anyone any ideas? :frowning:

2 Likes

Shortcuts are broken for me too.
Maybe it was the update that was just released?

Copy/paste between tabs stopped working in many cases. Sometimes the paste clipboard window opens for a split second, but even when it does stay open nothing gets pasted.

Win-10 64 Chrome

Update Also broken in Firefox.

1 Like

Broken for me too. I’m on a PC running Chrome. These hotkeys are so convenient for me. Hope they get fixed.

Sorry about this, this is a bug, should have a fix shortly.

Thanks, all! My bad. I busted this is 2.25.8. Just pushed a fix in 2.25.9.

2 Likes

Chord shortcuts fixed, however copy/paste is still broken (sometimes in the same tab.)
The only way I can get it to work is in a private window.
Add-ons that might interfere have been disabled.

@InvisibleLandscape, to help me debug - are you referring to copy + paste within the same project / browser tab? Or copy/paste between Hookpad instances? If the latter, when you perform the copy action, you should see a green notification in the lower right that says “your selection has been copied to the clipboard”.

image

Then when you paste in the new tab / Hookpad instance, instead of a keyboard shortcut try Edit (menu) → Paste from Clipboard.

In Chrome, for example, this brings up a permission dialog that I have to accept before the second instance will accept the paste from clipboard.

I’m trying to copy between tabs within the same browser.
Clipboard is allowed, and it doesn’t matter whether I use the menu, copy special, shortcuts, or if I’m pasting into an existing or blank instance of Hookpad.

The popup comes up saying the selection has been copied.
I use Brave instead of Chrome, but the same problem started in FF/Brave with 2.25.8

The reason I use copy/paste so often is because there’s no way to open an entire song from the TheoryDB in an instance of HookPad. Each section needs to be opened separately and manually combined, but I suppose that’s a different request. :wink:

In Brave first time I copy from one browser tab then try Edit → Paste from Clipboard in another, I see this permissions modal. I select “Allow”

I immediately see this “your clipboard does not contain valid Hookpad data” error from Hookpad in the “paste your clipboard here” modal. Not to fear.

image

I believe clicking the Brave permissions modal clears the clipboard. If I try to paste my clipboard directly in Hookpad right now it does not work.

I need to go back to the original project, copy some music again, then I come back and can do Edit → Paste Clipboard or use the keyboard shortcut “shift V” and copy + paste from clipboard works from now on between these two browser tabs.

It worked fine with Brave and Firefox before 2.25.8, then worked in neither after the update so I don’t think it’s browser specific.
I’ve never gotten that error regarding Hookpad data. Starting in 2.25.8 the shift+V window doesn’t show up at all. Only for a split second the first time I try to paste.
I tried clearing the clipboard permission setting in Brave, then if I try to paste again I’m asked to approve it, but it still won’t paste.

In Firefox if I open this as an example, create a new measure (7), copy the full chord starting at measure 5, and set the cursor to measure 7 it won’t paste. If I copy measure 5-6, highlight measure 7 and paste, nothing happens. The expected behavior in either case is the data is pasted in measure 7 and a newly created measure 8 (I have the auto-add setting enabled) which is what happens in a private Window.

Testing with Brave as well the bug appears to be related to creating additional measures when pasting. Pasting only works when enough measures are added prior to pasting.
I’m also unable to paste into an existing measure, even if it’s empty, if other measures contain data after it, but if it’s the last empty measure it will work.

Can you repeat with 2.25.9 or 2.25.10 both released 12/20/2022?

Here are videos showing single project copy-paste and “across browser tabs” copy-paste from clipboard in Firefox with 2.25.10.

Firefox doesn’t auto-accept the content of the “paste to clipboard” modal. There maybe something I can do to make that experience better in Firefox. I tried hard we launched this and couldn’t figure it out.

Hi Invisible, I’ve been using Brave for 2 months with no issues. I posted a new question a few minutes ago. I believe I’ve got this new update as well, and now transport keyboard commands aren’t working. As I read your post it appears that there may be some issues in this new release. I switched over to Chrome, re-opened, but there remains no function at least with the space bar for start/stop transport. Thanks

I appreciate the tutorial but just like shortcuts, I’ve used copy and paste between tabs in both Firefox and Brave thousands of times without issue until the same update broke both. :wink:

In a private window I can paste any number of measures into a single empty measure. In a normal window pasting only works if the number of empty measures is greater or equal to the number of measures I’m pasting, and is limited to one line at a time. If I have 12 empty measures I can’t paste 12 measures, it only works if I paste 8, then copy/paste the other 4 afterwards. :man_shrugging:

I’ve been using HookPad in a private window for the last 3 weeks which is annoying since my settings and open tabs aren’t remembered, but other than that it works as expected (2.25.7 and earlier.)