Hookpad not working PC and Android

Having bought and read the books (Android apps), I want to try the hookpad app before purchasing that too. In short, not working at all in Chrome on my Android tablet. Changed to the PC Edge browser instead, all the same problems, not working:

  • No sound on insert or playback on Android. Sound and media plays fine on other webpages, also theorytab. On PC, occasionally sound on the very first inserted chord, then nothing until refreshed with F5 (which also erases everything).

  • Chord insert works sometimes, then seems to get stuck. Placing the marker, trying to insert using click or number. On one occasion I succeeded inserting 3 chords right after each other using the keyboard, no reaction for the rest of the time.

All in all, this makes Hookpad not working at all, which cannot really be right… But since I tried with the exact same result on both PC and Android, I am a bit puzzled. Any ideas?


Every click on a chord when trying to insert generates a script typemismatch error in the error console of the browser:

  1. SCRIPT5022: TypeMismatchError

> [2.3fdbd3fe.chunk-public.js (1,1771919)](https://www.hooktheory.com/hookpad-app/2.5.0/static/js/2.3fdbd3fe.chunk-public.js)

Just for the record and to help others having the same problems with hookpad on Android or on PC (Edge browser): I now installed Chrome on my PC specifically for Hookpad, and it works, so I guess it is a compatibility issue in Hookpad. I hope you can solve it, as the benefits of a browser app should be at least that the mainstream browsers can be used.

Thanks for the report. Tablet use is not something we support at the moment (depending on the browser and platform it can work but the interface is not at all designed with touch in mind). On desktop, Edge has worked fine but perhaps something has broken, we’ll take a look.