Hookpad Keeps Auto Extending Melody Notes

I am working on my topline melody, and hookpad keeps extending notes from my midi to the 4 beat timeline grid. is this a functionality i can turn off?

Hi, I’m sorry to hear that. How do you input your melody? Are you doing a live recording with a midi controller or your computer keyboard?