"For parallel transposition to..." oddities

  1. Chords on degree 7 become borrowed from the major key only if actually switching from the major key. It might be preferable to do that regardless of the source mode (or vice versa, use the special behaviour for V only when changing from the major key) to keep things consistent.

  2. When changing to the minor mode, any chord on degree 5 becomes borrowed from the major key, including those which are already borrowed. The mode change should at least preserve all v (min) chords because most likely the author has decided that the minor-five chord is the intended harmony.

  3. This extends to applied dominants as well, which become something like V/ii (maj) regardless of the target degree. Of course it could have been a feature request to allow applied dominants of borrowed chords, and the chord symbols display properly too, but I doubt that would happen at any time so I will just put this here as a bug report.

  4. When mode changes are configured to be relative on the settings page, the menu in Hookpad might still display “parallel”.

1 Like

Thanks @HertzDevil, working on these items

Somewhat related: the message for “For parallel transpositions to minor,” checkbox is cut off for me (Chrome 52.0.2743.116 for Mac)

@semanticist thanks for the report. I just checked on a mac with the same version of chrome and am not seeing this behavior.

Maybe try emptying cache?

Anyone else having this problem?


Maybe try emptying cache?

No luck—and I’m also seeing the same thing in Safari (which I don’t generally use). I can try on a different computer later on.

Yes, I’m seeing the cut-off checkbox label on Windows 10, Microsoft Edge, using High DPI (125%). Interestingly, since the major update, the text in the Settings dialog is in Times New Roman, which is surely not what was intended. (Prior to that it was in Arial or Helvetica or a similar font.)