[Fixed] Error occurs when I try to open my tabs

Hey Forum

Everytime I try to open one of my projects I get this messae:

Error retriveing instrument specification XML https://s3.amazonaws.com/cdn.hooktheory.com/assets/sounds/standingwave/specification-htpiano-mp3.xml

Can anyone help me with this?

  • Somename

I am getting the same error message. Nothing is able to load up. Here is splash screen message I am receiving:

Error retrieving instrument specification XML https://s3.amasonaws.com/cdn.hooktheory.com/assets/sounds/standingwave/specifications/specifiation-htpiano-mp3.xml

Nothing else occurs, just endless “loading sounds” at 50%.

All, we are actively working on this. The problem is none of us can reproduce the error. Do you have any extensions in stalled in your browser? I’m leaning towards that being a possible cause.

It’s probably the S3 SSL certificate upgrade:
If you can’t access https://www.amazonsha256.com you may need to upgrade your browser or OS.

@semanticist: genius. @revdrdldavis, @somename, can you visit the link @semanticist posted from your browser to see if it works? If not, I have a feeling this is the problem. It explains why our staff can’t reproduce it. We will update our error message to reflect this.

I have confirmation from at least one user experiencing the specification error that this is not the problem. His browser was able to load https://www.amazonsha256.com/ and get the “Success” message but he still cannot load the specification error.

One user yesterday that reported this problem via email told me that deleting the cache in his browser fixed it. I’m not sure if this will work for any of you but if it does, please report back here.

I’m still actively investigating what is causing this problem. Stay tuned.


Ive been getting this message for about 2 days. The S3 SSL certificate worked on my browser (Chrome). However, clearing all of my browsing data including cache worked for me.

1 Like

Just started having the problem tonight - here is screenshot (well, if I wasn’t new to the forum I could paste a snip . . . )

"This site says…
Error retrieving instrument specification XML Https://s3.amazonaws.com/cdn.hooktheory.com/assets/sounds/standingwave/specifications/specification-htpiano-mp3.xml

and yes I get this when I go to other link:

Congratulations! Your negotiation to the AWS Test Endpoint was successful. Your client browser supports SHA256. You should have no trouble connecting with AWS over HTTPS after September 30, 2015.

Hey deleting my helped worked ! :slight_smile:

Deleting the cache in Chrome helped me too. Thanks!

clearing cache in Microsoft edge didn’t do anything for me . . . :frowning:

All, I pushed another update moments ago that I hope will fix this problem. Anyone that is still having this problem can you reload Hookpad and see if the problem persists (and report back here)? So sorry all of you have been struggling with this. It has been difficult to fix because we can’t reproduce the behavior you are seeing.

1 Like

All, thank your for your patience with this bug and helping us debug it. This morning we finally figured out its cause and pushed a fix to production. Thank your for waiting it out. The fact that deleting your cache fixed it was very helpful in leading us to the solution.

1 Like