Go to www.hooktheory.com

Chord Crush playing intro over the exercise

2 problems in Level Up but possibly related so reported as one bug
1 - instead of muting, the intro loop plays loudly and continuously over the top of the exercise (you can still see the exercise, just can’t hear it over the annoyingly loud intro)
2 - when starting ‘Try Again’ after loosing all lives, the screen reverts to the Level-Up menu screen but the exercise starts playing in the background (can be heard but not seen). Well, heard in the background as the intro is also playing!
In both instances, it’s necessary to abort and start again. It is very frustrating.
The problem occurs on both iPad and MacBook.

Seems to be particularly after pressing ‘Retry’. The screen shows the menu (and plays the intro) whilst the first exercise in playing in the background.

That happens to me too.

Thanks for the bug report. Is there a simple set of steps you could provide to reproduce? There’s a chance it might be associated with another bug we just fixed that was causing the key orienter to sometimes not play, and for random chords to sometimes play at the beginning before a puzzle plays. That update should be live tonight, so let me know if that helps at all.

I can confirm that your recent fix didn’t resolve this bug.
I avoided the problem by realising that I could turn off the Theme Song in settings- thank you! LOL - and then by never selecting ‘Retry’, always choosing ‘Continue’ instead.

This should replicate the issue for you:

1 - Make sure that Theme Song is not turned off in settings
2 - Go to Level 1-8 of Level Up. It’s probably the same for any level but this is the one I just tried
3- Run out of lives and you will get the option to ‘Continue’ or ‘Retry’. Select ‘Retry’
4- The screen reverts to the Level-up menu which makes you think that you need to select a level BUT if you wait a second, the retry challenge automatically starts playing in the background. However, you can’t see the screen to select the chords because the Level Up menu screen is still showing.
5 -If you then select a level to try to get to the screen you need, you finish up with Theme Tune playing and it continues to play even when the challenge screen appears. The challenges play in parallel with the Theme Tune.
(This text is copied from the email I’ve already sent to Ryan as I didn’t realise that I should respond in this thread for ease of reference and visibility to other users)

Thanks for the detailed report and steps, and really appreciate your help!

I can follow the steps until step 4. Here clicking “Retry” simply restarts the level (this is what we had intended) without going back to the Level-up menu.

What you’re describing however (going back to the level-up menu) is something that I’ve definitely seen before, but I had thought we had fixed. Can you confirm this is still happening in version 1.2.8?

Yep, still happening on 1.2.8. Tried on Mac, iPad and iPhone. Also, as a long shot, I tried different browsers. It always happens for me in Safari, Chrome and Firefox.

Could it be something in my settings?
Update: don’t think it is my settings as I’ve just replicated it in ‘private’ browser mode and not logging in, only using the free allocation.

Are you sure that what you are trying to replicate it on is identical to the version deployed to users? Just a thought.

@sbpiano, we finally figured out how to reproduce this bug, and have fixed it in 1.2.9, live now. Thanks again for your patience and for helping us out.

Yup, fixed!
Many thanks.