Can't load song projects

I can no longer load any song projects, I think since updating to version 2.31.10. Just gets stuck on loading. Have tried shift + refresh, different browsers, mobile and desktop but no luck.

Hi, I’m sorry to hear that. What is the last thing you can load? Can you open Hookpad at all? If yes, can you open the “Open Songs” Modal, can you see your songs being listed?

Thanks for your reply - yes, I can open Hookpad and open the ‘Open Songs’ modal, with my songs listed, but it gets stuck on loading when I try to open any of them.

Thank you for your quick reply. Is this for all songs or just a special one?

No, I can’t open any of my songs…

Following - I also can’t Open Hookpad - or Open My projects today

Hi there. I’ve been having the same problem for the last week. The 'Open Projects window is visible, but for ALL my projects, the cursor goes into an endless ‘loading’ loop. This is becoming frustrating because I have been using Hookpad to write songs for a musical, and I have an upcoming deadline on May 30. Would really appreciate swift action on this bug.
Thank you so much.

I cannot open any of the saved files since sometime early this month. But after I connected to VPN everything seems normal. If I quit VPN, the problem persists.

@abhishekpandit any chance you could do a screen capture that shows this happening? Not sure what you mean by the cursor going in an “endless loading loop”. Do you mean that when you click a song to open it shows a loading icon but nothing happens?

We’re not seeing anything unusual on our end, but hopefully we can find some clues from your experience

also helpful for all if you can post browser/os that you’re using for us to try to recreate your environment as closely as possible

I’ve recorded my screen but can’t see I can share a video capture here? So here’s a couple of screenshots - gets stuck on loading, and if I try opening in new window it gets stuck on ‘getting song data’.

I’ve tried it on Chrome (desktop and mobile) and Edge and tried via VPN too, but have the same issue with all.

Hi Ryan,
Thanks for looking into this issue.
It started happening in the last two weeks. Earlier this week, Hookpad did work fine for a week. I’ve previously run it on my Mac OS (Monterey) on both Safari and Chrome. Any idea what might be going on?
Could this be happening because I have too many projects stored in the cloud (200+)?

Screenshot below—