Go to www.hooktheory.com

BPM broken because of "tap tempo" [Fixed]


#1

I tried using tap tempo and when I clicked “Ok” it changed my BPM to NaN and will not allow me to change it back. I tried using both tap tempo and manual input but the BPM remains as NaN.


#2

Sorry for the delayed response. I have identified the issue and will work on a fix. in the meantime if you email support with the name of the song that is messed up we can also fix that for you.

Dave


#3

I still experienced the bug, is that anything that I can do?


#4

I noticed this bug when I first started using Hookpad. I just tried several attempts and couldn’t replicate the behavior - maybe a fix was applied but your song data is in a bad state? Did you try emailing support like Dave mentions?


#5

Hey all,
we recently identified one way this can potentially happen and will push a fix soon. if you have a song with a NaN tempo that you would like me to fix, send an email to support (at) hooktheory (dot) com with the your username and the name of your song and we can make it work again.

The cause that we identified was not actually related to tap tempo so it’s possible we didn’t solve it completely (if you made the tempo close to 0 BPM and lower tempo with arrows it would let you go negative which turned into a NaN). If you figure out another way to create the issue (reproducibly) let us know here and we’ll squash this annoying bug.

Thanks for your patience.

Dave


#6

Fix pushed moments ago with Hookpad 2.3.4. Thank you, all, for reporting this bug!