Go to www.hooktheory.com

When I play a melody out with the computer keyboard in record mode, the timing is off

I play it in the syncopated rhythm I want and I hear the notes sounding at the right time as I play them in, but when I stop it and playback, the notes are slightly delayed or before where they’re supposed to be. Why is this happening? Also is there a way to have a count-in from the place where you start recording? This is especially crucial if it’s the beginning of the song. It seems to count in (waits) but there’s no beeps.

Nearly at the bottom of the preferences there is a setting called “Recording Input Latency”.

It might help to check out a few different settings. I think with my machine I need something like 75ms to get the notes recorded to where I want them.

Please let me know if this helps!

Dennis

Thank you! This fixed it!