Problem with MIDI Export

Having problems with MIDI export.
It only exports the notes and not the full chords.

No help … ? I really want to know why this is happening, probably not a bug but i wanna know how
to fix this problem

@Enarca, what program are you using to read the MIDI files? We’ve had reports of having issues with our MIDI files in FL studio, which we are currently investigating.

I use FL Studio, and alright I guess that makes sense as to why it isn’t working for me.

I am having the same issue using FL Studio 11. Whenever I export MIDI files to load into FL it only brings in the note and not the full chords.

I was super excited for this feature and signed up hoping this would work! :smile:

Hi @Enarca and @KCEferrari,

We’re very sorry about the issues you guys have had with Hookpad MIDI files and FL Studio. We’ve done a complete overhaul of the MIDI framework to address this along with other issues that users were having with their MIDI files.

We’re currently testing out this new framework, but if you guys would like to try it out, please visit:

using the credentials:
u/n: demo
p/w: demo

Then log into your Hooktheory accounts, you can access your library of projects. The version of Hookpad on this special page has the new MIDI export framework for you to try out. Let me know if this fixes the problem for you guys.

Thanks for your patience!

@Enarca and @KCEferrari, I also want to point out that everything you do / save on our website will be accessible on our normal website,

Hi Ryan: there is also a MIDI Export Bug in Safai on Mac El Capitan. When you get to the Save dialog it just freezes and crashes Safari (i.e. Safari becomes unresponsive and I have to force quit). It worked in Chrome on El Capitan, so it seems to be a Safari specific issue.

Hope this helps.

Thanks @j3groove,

We experienced a similar issue. @chris said that upgrading his flash player fixed this issue. Can you let us know if that resolves this for you too?

Yeah, I experience the same problem. When I import midi into FL Studio 11.0.1 there’s only a melody. When I want import chords also, I have to delete all melody and export again. This is ugly workaround guys - at least until the support will fix the problem :smile:

I’'ve tried developer version but I cannot export midi there because of paywall.

i’m noticing the same thing as KrzysiekWu when importing MIDI files into FL Studio 12. if the song has a melody, the chords and bass tracks aren’t imported.

what’s changed in the midi export process that might cause this issue?

note: this issue doesn’t manifest when using Bitwig Studio.

The MIDI files exported from Hookpad are ill-formed; there are two end-of-track meta-events (delta time 00 followed by FF 2F 00) at the end of each track. MIDI files should only contain exactly one for each track, so FL Studio may refuse to import the rest of the MIDI.

1 Like

HertzDevil to the rescue <3

That’s interesting. Can I manually edit the file to repair this issue?

I’m guessing that importing it into software that properly open this ill-formed .midi and export from there will be faster than removing FF 2F 00 by hand (if it possible of course).

Hi all,

We’ve pushed a fix to the end of track issue, has this resolved the issue for you guys?

I’ve made a quick check and indeed this fix resolved the issue. Unfortunately it didn’t fix this strange chord inversion I’ve described here:

Is it another bug as Badonk says?