Chrome freezing the project page

Hi, enjoying the program very much, but it’s annoying when Chrome freezes the project page, right in the middle of composing. Do we have to use Chrome? I’m on an iMac High Sierra.

Chrome and Safari should both work fine on your mac. Can you clarify what you mean by chrome freezing the project page?


Hi, yes, the project page becomes blank, when I back page, nothing works when I click on anything. Also, in safari, midi input message Chrome only.

1 Like

I have the same issue (using Chrome). Twice today I lost all my work, about 2 hours’ worth! With the most recent incident, I attempted to split a chord and the work area on my screen went all white. How do I get my work back?

Yikes sorry! one thing that might help while we figure out what is causing the project to become corrupted: you can often hit ‘z’ for undo to get the song back in a previous ok state if it somehow got messed up with the previous action.

Sounds like there is an issue with splitting chords. Do you remember if there was something unusual about the chord (either it was especially complex or maybe was in a weird position or rhythm)?

If it happens again and you can hit undo to solve the problem. Please send a screen shot of the state right before you performed your action as this will help us reproduce.


Hello Dave, first of all sorry for my bad english.

I don’t know if this is the same issue, hookpad usually crash on my PC (Windows 10 x64) a few times every day. The page become completely white (blank) and it’s happening on both Chrome and Firefox.

So here are some information about my issue.
I have a music project that always crash the app if I try to edit (drag / resize) it’s chrods. Here is my music:

If I keep moving, draging, resizeing it’s chords than a few errors starts to show up in the Chrome’s console:

Note that you cannot see this errors without the console been openned.

So, most of the users don’t now this erros are happening and keep editing, and if you keep editing than the crash occurs:

As you can see, several erros happens at the same time on the console, the page becomes blank (completly white) and the mouse cursor keep showing this ‘chord resize’ image. I cannot undo anything with Z, save my project or any other thing, I just lose my progress. And this project that I created called “Boss” is especially broken cuz a few clicks on the chords and it crashs everytime, what is strange, because this project became broken (or corrupted some how) just a few minutes after I created it.

Just so you know it’s not a problem on my PC since not every project crashs, it’s random, some projects has this crash characteristic while other don’t crash at all.

I hope my thoughts can help fixing this issue because I keep losing melodies, hours of work and cool chord progressions.
Thank you and once again, sorry for my bad english. :blush:

Thank you for the detailed report. I’m looking and it seems this song was originally created in Hookpad 1.x and is being edited in Hookpad 2. Can I confirm that all the crashes are happening in these situations? I’m thinking there may be an issue with the conversion in some cases.


Hi, no , have only used HP2.

Thanks for the detailed report here. For this song “boss” is there something that you can do that always makes this crash? If so we can repeat those actions and figure out what’s going on

I just experienced this (Windows, Chrome) yesterday. Several times, in the middle of editing, the page turned blank and the project wasn’t saved. :frowning:

We’ve pushed a fix so that the error posted in @NecroToad’s console should not crash Hookpad. Please keep us updated as to whether this fix has had an effect on the crashing you’re experiencing

Hello Dave, short answer: No, it happens for me in a lot of different project, even when the project is created on Hook Pad 2.
Long answer: I tried to create this ‘I’ and ‘V’ rhythm at the beginning of my Boss song several times (on hookpad 2), and it always crashs after a few chords, I couldn’t even save it, bacause it crashs really fast. Then, to bypass this bug, I decided to create this rhythm on Hookpad 1 and then continue to edit the song on Hookpad 2. It almost worked! I was able to create the rhythm on HP1 but as soon as I star editing on HP2 it crashs. So, this specific project was created on HP1 but I tried to create it on HP2 several times and it crashs the same way.

Is my explanation a bit confusing? Were you able to understand?

Hello Ryan, As I said, I crashed the app by only moving the chords around, especially moving it’s bounds (like when you resize it to set it’s start and end points).

Thank you Ryan, I played a little bit with my Boss song, messing around with the chords in order to try to crash it, but I was unable to. I think you fixed it. :smiley:
If HookPad 2 crashs again I’ll let you know.
Thank you Ryan and Dave for your efforts! I really enjoy HookPad 2, much more than HookPad 1. Keep the good work!

I am not able to print it. My system get freezed when I pres print button Canon Customer service is not getting why this is happening. with it.