Go to www.hooktheory.com

Hookpad MIDI latency


#1

When using the Jazz plugin, I get too much lag for it to be usable, probably over 100ms. In a DAW I can just use ASIO for All and turn down the buffer size in the DAW. Not really sure what to do in this situation since it’s just through the browser though.


#2

@saws, I’m sorry you’re having issues with latency. I’m guessing you’re referring using the record mode with your MIDI controller? Unfortunately, since this is a browser plugin, i’m not sure how much we can do about this. I suppose we could try to compensate for the latency when entering in notes into Hookpad, but it’s still going to be annoying if you hear the notes late.


#3

Whoops, I was a little vague there. Yeah, I’m using the PC mode of my keyboard, MIDI to USB, which is what I normally do in a DAW. Thanks for the response. If I get a chance to test things on different setups, like a different computer or MIDI controller I’ll report my results.


#4

Did your tests have any results you can share? Thanks.


#5

Having the same issues here.
Just upgraded to plus as I was really looking forward to this feature.
If anyone has a solution…

If it isn’t possible to get this working the feature of being able to upload midi files is a good alternative as you can then do it in your own DAW…

By the way, maybe http://www.audiotool.com/ did solve this? Never used they’re site, but everything they do is online.


#6

Hi all,

We’ve updated the Hookpad page to interface with MIDI instruments using the Web MIDI API, which offers browser-level support for the MIDI interface. Unfortunately it is not supported in all browsers yet, but it is built into Chrome. Browsers that don’t support the web MIDI API fall back to the Jazz Soft plugin.

You might try using Chrome to see if this speeds up this latency for you.

Ryan


#7

Hello Ryan,

I am using Chrome and having the same issue which makes real time recording using MIDI impossible because of the latency. Can you provide more information on getting the latency down to a reasonable setting like 10ms or less? Step editing works perfectly but it is a pain to keep having to change note values with one hand while entering notes using the MIDI keyboard with another. This is an important feature that many of us upgraded to a PLUS account for and would expedite creating tabs and songs.

Musically yours,
Stephen J. Souza


#8

Hi @musicianman,

Very sorry this issue is persisting. We have not yet identified why some users are having this latency whereas other users do not have any problems.

One theory is that there is some latency within the sound playback engine that is causing delays. We’re going to do two things to address this. The first is that we are transitioning our Flash-based sound engine to a javascript one based on the web audio API. Since this sound engine runs from the browser it should be much more efficient that the Flash one.

The second thing we’re going to do is put a debug version of Hookpad on our development site that will output some diagnostic information regarding the MIDI entry. This will hopefully give us some more clues as to what is going on.

Thank you for your continued patience.

Ryan


#9

Hello Ryan,

Thank you for the informative response and providing your action items. It’s a good idea to drop Flash which has had it’s time. The delay issue occurs when trying to record using the computer keyboard as well. Please keep us posted on the progress, I know I am looking forward to this fix :slight_smile:

Musically yours,
Stephen J. Souza


#10

@musicianman,

I fear that this latency may end up being related to our implementation Hookpad in Flash. We are committed to moving Hookpad off of Flash as soon as possible (our sound engine as of this month has migrated to JS), which will definitely improve performance significantly.

In the meantime, please feel free to log into our development site: dev.hooktheory.com/hookpad with the following credentials:

u/n: demo
p/w: demo

We have pushed a version of Hookpad there that is echoing some debug information in the console regarding the timing of the midi inputs and commands to our sound engine that can hopefully shed some light on how your experience is differing from other users.

Best
Ryan


#11

Hello Ryan,

Thanks for the update. I logged into the demo dev site testing things out to give you some data to debug the issue. I will continue using the site when I can. Please continue to provide updates from time to time until this timing issue is resolved.

Musically yours,
Stephen J. Souza


#12

Any progress with the midi latency? I would like to input with my midi controller but there is too much latency for real-time entry. Also Hookpad does not recognize the note duration, it is stuck on 1/8 notes for each note I enter and I manually have to select a different duration…can it not detect note duration automatically from my midi controller?
Thanks


#13

@4johnny,

To adjust the duration, you can choose a different value from the duration gui which sets the default duration for note/chord lengths until the next recorded midi event. I understand this workflow is not optimal and we are working to come up with a simpler solution.

Regarding latency, there are a couple of issues. The first is the latency associated with playing a sound from Hookpad after you hit a key on your controller, and the second has to do with where the entered notes go on the Hookpad timeline. For the first issue, we are somewhat limited by the way that Chrome receives midi messages and generates audio. We’re working on optimizing this to be as fast as possible, but this may ultimately be a machine/browser limitation. For the second issue, we’ve experimented with having a setting that you could adjust if you notice that the inputs are coming in too early or too late. Of course, we welcome your feedback as well as how to best address this for your needs.